Jump to content

Welcome to Ultima Online Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Welcome to UOForums

If not already a member, take a moment to join our awesome community. It is free to sign up and there are no ads.

 

When you click on CREATE ACCOUNT, the sign up form will appear at the bottom of the forum.

 

If you have issues, like not receiving a validation email. Then please contact us by email help@uoforums.com and we will help you get set up.

 

If you wish to contact us about our site for other reasons, then please contact us by using the contact form in top right corner of the forum


Photo

Things that make you go *sigh*

- - - - - make sigh things

  • Please log in to reply
7 replies to this topic

#1
Mystic Princess

Mystic Princess

    Newbie

  • Members
  • Pip
  • 7 posts
Hello :)

Ok just came back after a 2 year break, both my hubby and myself.

I dl stygian etc all that advanced client, this was last week, my computer is a very nice one brand new dual core it playes Vanguard like no one else plays and no lag no hitching, its smooth as a babies bottom.

Ultima - *cries* I load it, I get more black than I do graphics, when the graphics decide to load I am walking so slow, terrible lag, terrible hitching, I seem to fly forward (prob lag and stuff duno) 8 squares when I think I have walked one.

I performed a full wipe of my comp (its new *sob* I have now done this four times and it's getting old and frustrating).

Speed tests shoot me way above the hubby, who insidently is on a bag of **** computer :) well its nice it's my old one, and he has 0 lag 0 problems.

I did ask on stratics and they did guide me here, I was being patient until all the probs had been sorted, we purchased the game upgrade and all that, had the patches etc, and I am as I was originally still the same the only thing this all changed I don't get the swimming graphics on the screen that is sorted.

Did a full computer speed test etc and all that stuff I don't really understand but perhaps someone does, and please help me want to play so bad but its just making me more and more moody :( and sad.

The computer is only three weeks old and I have spent the last week formating and re-installing to try to get UO to work and I just don't get it.

Windows XP 32 bit
ASUSTeK computer INc Mother board Rev 1.xx
CPU Intel Core 2 Quad Q9550@2.38GHz
Measured Speed 1885.2MHz
Multiplier 6x
Bus Speed 333Mhz
Front side Bus Speed 1333Mhz

Cashe per CPU package
L1 Instruction cashe 4x32 KB
L1 Data Cash 4x32 KB
L2 Cache Size 2x6 MB

Memory Information
Total Physical 3326 MB ram
Available Physical 2642 MB Ram

Memory Devices
Slot 1 DDR2, 2048 MB, 1066MHz
Slot 2
Slot 3 DDR2, 2048MB, 1066MHz
Slot 4
Virtal Memory 904 MB

(Note I am partitioned x3 )

Disk Info
(1) Disk Size Free space - 195.3 GB (151.5 GB)
Model : SAMSUNG HD 1031JJ
(2) Disk Size free space - 432.4 GB
(3) Disk Size free space 100.1 GB
NTFS

Video Adapters
NVIDIA GeForce GTX 285
Memory 1024 MB

Monitor 1440x900x32 60Hz

One other HD half a terra one other external half terrabite.

Now Vanguard patches mega fast , it runs smooth, why can't I run UO im stumped and badly in need of help, it would be hugely appreciated.

Thank you all for your time and patience with me
Huge Hugs -Myst-

#2
Tancred RedStar

Tancred RedStar

    Balron Snack

  • Members
  • 5,379 posts
Make sure your DirectX and video card drivers are current. Regardless of you internet connection or RAM, if those are not up to date you can have issues.

#3
Mystic Princess

Mystic Princess

    Newbie

  • Members
  • Pip
  • 7 posts
:) Yup all nicely nicely driver doctored and up to date, nvid the lot, first thing really we tried :) forgot to mention that bit sorry :)

#4
Mystic Princess

Mystic Princess

    Newbie

  • Members
  • Pip
  • 7 posts
Did a brand new hard drive today, and a fresh install of all drivers, direct x, updated all things intalled windows xp again 34. Still black sections and still lag :( so no joy
Posted Image

#5
Mystic Princess

Mystic Princess

    Newbie

  • Members
  • Pip
  • 7 posts
Well after a solid week of formating, jiggling, switching graphics cards and cleaning the kitchen until you needed sunglasses to go in there due to streess, the hubby finally got it all working... this is what I have to do each time I load Styg

1. Start Stygian abyss (proper start it)
2. Start Task Manager
3. Processes Tab:- Rt Click UOSA.EXE + Choose "Set Afinity" - Un-tick Nos 2&3 or 3&4 depending on the system.
4. Close task manager.

No more lag, no more glitches, no more swiming screen, its a fix I am happy with for now :) it works I work ahhhhhhh waight lifted, my poor new computer has been through the mill, it might help someone else hopefully.

Only thing you have to do it each time you start UO pfft who cares :D if it works and its not hurting my machine let it go leeeetttt itttt gooo ;)

Thanks for listening to my insane babbling.

Myst
Posted Image

#6
Lord Target

Lord Target

    I know I am, and so are you. Now I must throw giant waffles at y

  • Members
  • PipPipPip
  • 475 posts
I'm glad you got it fixed. The problem itself is very odd.

Perhaps this indicates that the new client has issues being handled by multiple-core processors?

Anyone else experience this issue?

 


#7
Father

Father

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts
Yeah I have a tri core, And I can't run the new client, SO I use the old one.

#8
Lord Target

Lord Target

    I know I am, and so are you. Now I must throw giant waffles at y

  • Members
  • PipPipPip
  • 475 posts

Yeah I have a tri core, And I can't run the new client, SO I use the old one.


Anyone who just wants to fix this and wants to bypass reading a lot, scroll down for solutions.

An update regarding this, I've only ever used dual-core LGA775's and worked on a few X2's, but some other folks have experienced the same issue with their games.

Permanently "Set Processor Affinity" - GameDev.Net Discussion Forums

Some folks there commented that they used different launchers to configure different apps to ALWAYS run with the affinity selected.

Others mention that certain "features" in their hardware [such as cool n' quiet and the nvidia firewall --activearmor] seemed to be exacerbating the issue.

There were also others who claimed that the appropriate software update from the chipset/processor manufacturer fixed the problem.

Mars999 says:

Just to state this under Nvidia drivers .pfd file it tells you how to shutdown the dual CPU support for DX / GL. I did this and fixed my issues I had with any games. Now my engine I use the High Res timer and my engine is jumpy, unless I ctrl alt del and turn off one of the cpus for that app...

and further down, Shannon Barber points this out about SMP:

0.o SMP makes a tremendous difference to any mutli-threaded application.
On a signle core system only one thread may be physically executing at a time, this hides many would-be race conditions. On an SMP system two (or more, however many cores there are ) threads are physically executing at same time. This drastically increases the likelihood that a race will be lost. (Note that all race-conditions are bugs but some can happen very rarely.)

The RDTSC is processor dependant and many high-performance applications (games & VMWare for exmaple) use the RDTSC for a high-resolution timer. On x2 CPUs there's 2 RDTSC that are not sycronized (fails the monotomically increasing requirement for timers).

a little further down, I found this post by Gumpy:

AMD Dual-Core Optimization Utility Available

Quote:
AMD has silently released a utility that fixes time stamp counter (TSC) issues with dual-core AMD processors such as the Athlon 64 X2 and Opteron. The AMD Dual-Core Optimizer utility is a driver that synchronizes the time stamp counter on both processor cores and improves game compatibility and performance. Time stamp counter issues occur in older games that are incompatible with multithreading and would run too fast or out of sync.

and this post by Ravuya...

Look what I found on ArsTechnica: WinXP Launcher, SMP SeeSaw. It apparently doesn't work for Deus Ex (you have to run that in win98 mode), but it should work for you. Enjoy!

and also this post by Extrarius;

Actually, AMD released a patch called "AMD Dual-Core Optimizer" that fixes 'rdtsc' in the same way the basic processor driver (or maybe, the MS patch mentioned in this thread) fix 'QueryPerformanceTimer'. I have the driver, the MS patch, and the 'Dual-Core Optimizer' patch all installed and things work very well now. I think the MS patch is likely unneeded, but I haven't tested without it and it doesn't seem to be hurting.

I didn't bump the thread with that info since it was in another more recent thread, but since it's up here anyways, might as well mention it.

and finally, this post by Nypyren:

Once upon a time, someone linked this:

Microsoft Application Compatibility Toolkit

One of the MANY compatibility fixes buried in the "Compatibility Administrator" deals with the single processor affinity fix, which you can apply for specific programs.

This worked for all of the problems I've had with my X2 so far.

Hope that helps!:)


EDIT: Found this XP Service Pack 2 Fix for dual-core intels.

I did not see it listed under the SP3 updates, so give it a shot if none of the above fixes it.

 






Also tagged with one or more of these keywords: make, sigh, things