Jump to content

Welcome to Ultima Online Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Welcome to UOForums

If not already a member, take a moment to join our awesome community. It is free to sign up and there are no ads.

 

When you click on CREATE ACCOUNT, the sign up form will appear at the bottom of the forum.

 

If you have issues, like not receiving a validation email. Then please contact us by email help@uoforums.com and we will help you get set up.

 

If you wish to contact us about our site for other reasons, then please contact us by using the contact form in top right corner of the forum


Photo

House placement issues

- - - - - house issues placement

  • Please log in to reply
3 replies to this topic

#1
iheartcullens

iheartcullens

    Phoenix Goddess

  • Members
  • PipPipPip
  • 37 posts
Ok, I placed a customizable house a few days ago, but i realized that i couldn't afford to customize it the way i wanted it. So I demolished it and they put the money back into my account. Now I can not place another one, the house placement tool isn't working at all. whats the deal??

#2
kitiara

kitiara

    Polar Bear Queen

  • Members
  • 3,769 posts
  • LocationHarrisonburg, VA
There's a one-week wait time between placing houses. You'll be able to place another after 7 days.

#3
iheartcullens

iheartcullens

    Phoenix Goddess

  • Members
  • PipPipPip
  • 37 posts
Ah alright. Well I was lucky enough to find a guy who was nice enough to give me two ships to store all my stuff so I didn't have to have all my packies and worry about them, til I can place my house.

#4
kitiara

kitiara

    Polar Bear Queen

  • Members
  • 3,769 posts
  • LocationHarrisonburg, VA
FYI on top of that, it looks like the house placement function has been broken all day. Found a thread on Stratics about it, starting early this morning. I just tried my house tool and it gives a message that the housing system is currently down, try again later...





Also tagged with one or more of these keywords: house, issues, placement