Jump to content

Welcome to Ultima Online Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Welcome to UOForums

If not already a member, take a moment to join our awesome community. It is free to sign up and there are no ads.

 

When you click on CREATE ACCOUNT, the sign up form will appear at the bottom of the forum.

 

If you have issues, like not receiving a validation email. Then please contact us by email help@uoforums.com and we will help you get set up.

 

If you wish to contact us about our site for other reasons, then please contact us by using the contact form in top right corner of the forum


Photo

UO:KR!!! Need help with pet commands and macros

- - - - - commands macros pet uokr

  • Please log in to reply
7 replies to this topic

#1
mistressmarabeth

mistressmarabeth

    Someone has been eating the Play-Doh again...

  • Members
  • PipPipPip
  • 96 posts
Hey guys I need a little help getting my pet command macros to work properly. I am used to the macros in 2d when I hit my keys my char says all kill I get a targeting cursor to select the monster that I want my pets to attack. In KR there is no targeting cursor and I have had my pets chasing me!! LOL, it's not fun to run from a p.o.'ed rune beetle and nightmare! I have tried to set it up in the macro so that it gives me a targeting cursor after I issue the command but it does not. The only way that I can get this to work properly is to select the monster first so that cursor is already on it then give the command to my pets. This is not so good when I am in a dungeon and heal myself, then forget to move the target cursor and I wind up with my pets joining up with the dang fan dancers chasing me while I scream in frustration. I have searched through the user guides and can't find anything. Any help would be much appreciated!! Thanks!!
Pixie Sticks.....for kids who can't afford heroin.=)

#2
Moony

Moony

    Legendary Sampire

  • Members
  • PipPipPip
  • 156 posts
Umm, set the macros so they use "target cursor" instead of "target current target" or "target self"

If that doesn't work, idk =)
GM in: Dying and Running Away, then Dying

#3
Baldguy

Baldguy

    AKA Thom O'Bedlam. Got a Question? I got a link for ya!

  • Members
  • 1,948 posts
Not KR user, but we have quite a few. I will edit this post title to reflect UO:KR quicker respones.

Useful links


[UO:F Common FAQ] [UO Guide] [Official UO Play Guide] [UO Feedback] [More Links, gathered by the Forum]
[B][SIZE="3"]Got a Question, or a great answer? PM me with it and I will post in the FAQ.

#4
Gyvalor

Gyvalor

    collecter of death robes

  • Members
  • PipPipPip
  • 359 posts
I believe Moony has the correct answer. by default the macros seem to be set to Target current target. by left clicking on the macro you can see your choices and you will need to choose "Target Cursor" also I dont know if this bug has been fixed but you will need to say your commands in all lower case letters (NO CAPS) or your pets won't listen to you anyway.
Posted Image

#5
Merion

Merion

    Infamous King of Typos

  • Members
  • 2,023 posts
Another way of fixing this prob would be:
Drag the All Kill Icon from your macro-gump into your hotbar at the bottom of the screen (or any floating hotbar). Then right-click it and a little context-menue should open. Now, when you hover your cursor over "Target" it should open another little list with the options "current", "cursor" or "self". There you select either cursor oder current, as you like best.
having done this, you right-click again and simply define a hotkey for it.
... and you're done :D

#6
mistressmarabeth

mistressmarabeth

    Someone has been eating the Play-Doh again...

  • Members
  • PipPipPip
  • 96 posts
there is no option when i right click to set target. that is the problem. with the spells in my hotbar i have the option of setting the target with the pet commands it is not there. there is no "set target". i have tried everything and on stratics forums they said it was a bug and to report it, that it used to give you the option to "set target". I even had a few other people test it out and they said that when they first set their macros up they were able to set the target, but when they went back now and tried to set it that the option is missing like for me. so hopefully it will get fixed in a future patch and when it does i will able to go hunt with my pets. until then my tamer will play in 2d and the rest of my chars can stay in kr. lol. thank you all for your help.:D
Pixie Sticks.....for kids who can't afford heroin.=)

#7
Merion

Merion

    Infamous King of Typos

  • Members
  • 2,023 posts
Oops, you are right!
That option really is only there for spells and such, for spoken commands as "all kill" it is missing. It should bring up the targeting cursor though....

But yeah, thats definitely bug that should be reported!

#8
Truwen

Truwen

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts
Edited, wow I just realized this is a year late. Sorry.





Also tagged with one or more of these keywords: commands, macros, pet, uokr